WPCloudDeploy Documentation

Ubuntu 24.04 Notes

WPCD includes experimental support for Ubuntu 24.04 with NGINX web servers.  There is no support for it with OpenLiteSpeed web servers at this time.

Before using this version of Ubuntu, please read the important notes at the bottom of this document.

Installation

To install Ubuntu 24.04 with a new server there is a new drop-down option on the server deployment screen:

 

Global Settings

There is an option in SETTINGS to make it the default in the settings area:

Supported Providers

  • DigitalOcean
  • Linode/Akamai
  • Vultr
  • Hetzner (x86, ARM not supported)
  • Exoscale
  • UpCloud

Important Notes

Since this is an experimental feature, there are lots of caveats:

  • The feature is only available on WPCD versions 5.8 or later.
  • As mentioned earlier, OpenLiteSpeed servers are not supported – we are waiting for them to update their installation script to support it.  We do not expect this to be available anytime soon.
  • Not all optional server components are supported.  You might get strange results with components such as NETDATA, MONITORIX, GOACCESS, MONIT etc.  We have not fully tested these packages yet.
  • You might see a warning under the server list HEALTH column stating “Updates Check Error Notice: Please run all updates manually!”.  This is because Ubuntu 24.04 was released with a bug in the update-notifier package. Learn more about bug #2064624.  It’s been fixed but might take a while to be rolled out.
  • Only a handful of server providers are supported.  However, you will need to make sure you install the latest version of the WPCD Server Provider add-on plugins.
  • If we go by the history of Ubuntu 22.04, the big-three providers (AWS, Microsoft & Google) will not make Ubuntu 24.04 images available anytime soon.  It will likely be close to one year from the release date of Ubuntu 24.04 before server images are available for us to use on those providers.
  • You will not be able to install PHP versions earlier than 7.4.
  • The PHP module IMAGICK is not yet available so WordPress will not be able to use it for image operations.

You should only install this version of Ubuntu for testing, especially if you are attempting to install optional packages such as NETDATA.  Many 3rd party packages are not yet certified and installing them can cause serious system instability.

Related

All About Ubuntu LTS Versions

Share: