PHP v7.4.26 Breaks Some Things…

The most recent minor version of PHP 7.4 (PHP 7.4.26) was released on November 18th 2021 and, unfortunately it seems to break some things.

Normally, minor PHP versions are just bug fixes. But this particular version changed the version of some required dependencies – which actually makes it a much bigger update than you might have expected.

It requires the latest version of libpcre2-8-0 (currently 10.39).

PHP 7.4.26 really should have been named 7.5 under semver.

Anyway, it means that new servers where the most recent Linux updates have not already been applied will break if PHP 7.4.26 is installed.

Practically speaking, for WPCD, this means that you cannot do anything with your new servers unless you run Linux updates first. This is because we automatically install the latest version of PHP on all new servers – which means we end up installing PHP 7.4.26. But to keep the provisioning process to a reasonable amount of time we only run the first set of security updates overnight.

One of the issues is that, even when nightly security updates are run, the required updated libpcre2-8-0 dependency for PHP 7.4.26 isn’t installed because the new version of libpcre2-8-0 has no security related fixes. The only way to update it is to run all the Linux updates, not just the security updates.

This might become an issue for existing servers if a future version of PHP 7.4.x is a security update since it will be automatically installed. If this happens, you could wake up and find that your existing servers which were running fine all along will no longer do things like install new sites, clone sites etc.


To resolve this issue for new servers we have released version 4.12.0 of WPCD. It’s currently in the fast-ring branch so you’ll need to manually download and install it. This will ensure that your new servers work properly immediately after they have been deployed.

For existing servers, we recommend that you run your Linux updates to get the updated dependencies. This will prepare your server for PHP 7.4.26 or later if its ever installed as part of a security update.

Right now, your existing servers are likely running PHP 7.4.25 or earlier. 7.4.25 was the last version that was part of a security update and would have been automatically installed. We don’t expect that 7.4.26 will be automatically installed because it doesn’t seem to have any security related fixes. But by running your Linux updates now, when the next security update for PHP 7.4.x is applied, your servers will already have the new versions of the required dependencies so everything will keep working properly.

Note: experienced server admins can just run apt-get install -y libpcre2-8-0 from the command line instead of running all Linux updates.

Was This Article Useful? Or do you have questions or comments about it (or our products & services)? We'd love to hear from you!

Please enter your name.
Please enter a message.
You must accept the Terms and Conditions.
Please check the captcha to verify you are not a robot.

Automatic Notification Of New Articles

Sign up to get automatic notifications of new articles.  This is a different list than our standard list - you only get new articles once a week (usually on Mondays).  No other emails will be sent unless you sign up for our general list as well.

Posted in